0

I want to make search available to everyone who uses the site, including anonymous users.
Now, if i go to /admin/people/permissions and and try to enable "use search" for anonymous and authenticated users, the systems seems to act okay, but when I look at it again, nothing's changed. The settings seemingly won't remember my settings. Any ideas? I hope that there's something totally simple I forgot

EDIT: in fact, it does not keep any changes in the permission system.

EDIT 2: I made it work by editing permissions through /admin/people/permissions/roles. Does anyone has any ideas why it was possible in one way but not the other?

2
  • 1
    Sounds like a bug; did you try on a clean install? Commented Jul 12, 2013 at 1:06
  • no, I've done a fair number of them, and that's the first time I have this problem. That's exactly what makes me wonder.
    – Dalmaz
    Commented Jul 12, 2013 at 9:52

1 Answer 1

1

PHP has a default setting of 1000 for max_input_vars, and once you have a significant number of modules and/or roles defined, you end up with an excess number of permissions boxes on the page.

In your php.ini file add max_input_vars = 1500 and keep incrementally increasing it until it saves.

1
  • 1
    ...and, re: edit 2, with only one role shown, you are under this limit.
    – Jimajamma
    Commented Jul 12, 2013 at 0:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.