0

My Drupal 6 site should always display in French for all users except me. I need to administer the site in English.

Using the Locale module I have both languages installed and default set to French. In the language negotiation settings ('Configure'), I have selected 'none'. The help text says that "users may (optionally) select a preferred language on the My Account page".

Even though I have selected English in my account settings (under "Language settings"), everything remains in French when I login?

1

It doesn't seem to work like that; see Drupal: changing language settings in user edit not working.

If you had the Language negotiation set to None, because -- like me -- you thought that would allow users to change their language preferences, you were wrong. The problem is this help text on the Languages page is completely misleading:

None. The default language is used for site presentation, though users may (optionally) select a preferred language on the My Account page. (User language preferences will be used for site e-mails, if available.)

It should read:

None. The default language is used for site presentation, though users may (optionally) select a preferred language — for site e-mails, if available — on the My Account page.

2

Have you tried using the Administration Language module?

This module lets the administrator see all administration pages in her preferred language.

You can use this to display the frontend of the site in one language and still keep most of the backend in English (or another language of your choice).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.