1

following this tutorial I create a Panel Page for the taxonomy term to display all the content related to the taxonomy term and it works.

But I need to have in all the nodes related to the taxonomy terms in the url and children. So I sobstitute taxonomy term ID contex filter with taxonomy term ID (with depth) and do not work anymore -.-

This is the contex filter's settingcontex filter's setting

If I try this view block in view page [putting 'taxonomy-name' as argument] it works but not in the panel page.
Where is my mistake?

I don't know if this can help. This is the contex of panel page [I setup the view to take argument from URL.. but maybe it can help]
enter image description here

0

You should try to add a "Content pane" display on the view instead of using a page display (enable "Views content panes" module). "Content pane" allows to set the argument input from the views settings. On the "argument input" you can select "From context" as source, and the required term context.

EDIT: Like I've wrote on the following comments, the correct contextual filter settings is:

1) Content: Has taxonomy term ID (with depth). Provide a default value: Taxonomy term ID from URL (Load default filter from term page). Specify validation criteria: Taxonomy term, Filter value type: Term ID

2) Content: Has taxonomy term ID depth modifier

  • I already tried this solution but do not work too. I do not understand why if with "Has taxonomy term ID" context filter work and with depth do not work.. – Shyghar Jul 17 '13 at 13:26
  • Recently I've used Views + Taxonomy Display instead of views + Panels module. With Taxonomy Display you can select a views block and substitute the default term display, maybe this module could help you too. If you want display all nodes with the current term and all children nodes (on every depth starting from the selected term), you have to use two contextual filters: 1) Content: Has taxonomy term ID (with depth). 2) Content: Has taxonomy term ID depth modifier. – FiNeX Jul 17 '13 at 13:39
  • 1
    The configuration of the first contextual filter should be something like: Provide a default value: Taxonomy term ID from URL (Load default filter from term page). Specify validation criteria: Taxonomy term, Filter value type: Term ID – FiNeX Jul 17 '13 at 13:43
  • Thank you form help! I changed the validation criteria from "Term name converted to Term ID" to "Term ID" and now it works ^^ – Shyghar Jul 17 '13 at 14:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.