1

I used Drush to install Amazon S3 module. AWS SDK was installed as part of the process. No error was thrown

[root@ip-10-128-146-179 zencoder]# drush dl amazons3
Project amazons3 (7.x-1.0-beta7) downloaded to                         [success]
/var/www/html/drupal/sites/all/modules/amazons3.
[root@ip-10-128-146-179 zencoder]# drush en amazons3
The following projects have unmet dependencies:
amazons3 requires awssdk
Would you like to download them? (y/n): y
Project awssdk (7.x-5.4) downloaded to                                 [success]
/var/www/html/drupal/sites/all/modules/awssdk.
Project awssdk contains 2 modules: awssdk_ui, awssdk.
The following extensions will be enabled: amazons3, awssdk
Do you really want to continue? (y/n): y
amazons3 was enabled successfully.                                     [ok]
awssdk was enabled successfully.                                       [ok]

Now I see an error in my Drupal admin dashboard:

Failed to load the AWSSDK
Please make sure the AWSSDK library is installed in the libraries directory. Use the drush make file for easy installation.

What shoud I do?

This is my drush status:

Drupal version                  :  7.22                 
 Site URI                        :  http://default       
 Database driver                 :  mysql                
 Database hostname               :  localhost            
 Database username               :  drupal               
 Database name                   :  drupal               
 Database                        :  Connected            
 Drupal bootstrap                :  Successful           
 Drupal user                     :  Anonymous            
 Default theme                   :  bartik               
 Administration theme            :  seven                
 PHP configuration               :  /etc/php.ini         
 Drush version                   :  5.9                  
 Drush configuration             :                       
 Drupal root                     :  /var/www/html/drupal 
 Site path                       :  sites/default        
 File directory path             :  sites/default/files  
 Temporary file directory path   :  /tmp
1

Using the AWS PHP SDK version 1.6.2 instead of the latest solved the problem. sites/all/libraries/awssdk/sdk.class.php does not apply for at least version 2.1.1.

| improve this answer | |
0

Simply download the AWSSDK library and extract it to your sites/all/libraries folder following the format sites/all/libraries/awssdk/sdk.class.php.

| improve this answer | |
  • sites/all/libraries/awssdk/sdk.class.php does not exist for the latest version of AWS SDK for PHP. So I had to use version 1.6.2 – ericn Jul 22 '13 at 13:41
  • version 2.0 wasn't out when release 5.4 was created. So yes you were supposed to use version 1.6. My guess is it now works for you. – 4life Jul 22 '13 at 14:07
0

I ran this command from the Drupal root after installing the awssdk module and it worked:

drush make --no-core sites/all/modules/awssdk/awssdk.make

By worked, I mean it set up the library and fixed the "Failed to load the AWSSDK" error.

The command is referenced here: https://www.drupal.org/node/1353114#comment-5300564

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.