1

I am using domain access module with sub domains and content creation.

I am able to create content but I am not able to view content which was created by the user, it says You are not authorized to access this page where as admin I am able to create and view content.

In my another local site I tried domain access module and for other roles I am able to crate and view and edit the content. I don't have any issues. Same settings only I have for my another site.

But still it throws me this error You are not authorized to access this page after creating a content and in view section it shows this error.

Is any other module causing this issue?

  • I am getting that entry too in my db as 42 | 0 | domain_site.i have enabled both domain and subdomian site. (Select if this content can be shown to all affiliates. This setting will override the options below, but you must still select a domain that "owns" this content.) – Ram Jul 22 '13 at 7:36
  • Done all mentioned things still i am getting this error 'You are not authorized to access this page'.If i log in as admin and edit and save that page, then i can able to view that page in the user too. Can any one point me wats the mistake ? – Ram Jul 22 '13 at 8:03
  • Hello. Could you try make question's title a bit more specific? Now it does not provide any information not covered by tag domain-access. – Mołot Jul 30 '13 at 7:59
  • @Molot: Changed.Hope u provide me with a solution :) – Ram Jul 30 '13 at 8:01
  • Still i am getting this same error 'You are not authorized to access'. In permissions if i give ' Bypass content access control' as checked for a particular role i am able to view content,but i know this is not safe or secure to give permission like that.Any one any suggestions? – Ram Jul 30 '13 at 17:50
0

My answer is based on experience with D6 version of the module but I believe the core is still relevant. As the site administrator (user id 1) you can view all site content unless you disable that option in the domain settings page (Administer >> Site Building >> Domain >> Domain Settings >> Domain module behaviors fieldset >> Enforce rules on administrators:).

With relation to content viewing for other users, it is the default behavior to return HTTP 403 (Not authorized) when a content created specific to one domain without being shared to all affiliates is viewed from a different domain. The option to publish node to one or few of the sites is available in the node creation or edit form.

If you wish to change the default behavior of specific node types, the option to either allow specific node types to be published to all affiliates can be found in Node settings under Domain. When nodes are saved that way domain access table has an entry for such nodes with affiliated domains as domain_site.

| improve this answer | |
  • I am getting that entry too in my db as 42 | 0 | domain_site.i have enabled both domain and subdomian site. (Select if this content can be shown to all affiliates. This setting will override the options below, but you must still select a domain that "owns" this content.) – Ram Jul 22 '13 at 7:33
  • Any one know what i am doing wrong? – Ram Jul 29 '13 at 10:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.