• I am having 2 taxonomy vocabularies
    • Cars
    • Make
  • and I have Installed all needed modules to generate automatic URL, such as Path, Pathauto, tokens etc..
  • I have set patterns for these taxonomy vocabulary terms
    • car :car/[name]
    • make : car/make/[name]
  • in the "Cars" vocabulary I add a term and checked the "Generate automatic URL alias" option and save I see the path has been changed according to the pattern I have set. but in the "make" vocabulary terms when I check "Generate automatic URL alias" and save I don't see the URL created according to the pattern but (taxonomy/term/tid), when I click edit on the term I don't see "Generate automatic URL alias" checked it is simply unchecked.

Tried fixing it by doing some pathauto settings, google search my bad I didn't find anything similar.

  • anyone please?? – DropDragon Jul 25 '13 at 5:47
  • Make sure you don't already have expected-to-be-generated alias in the system (check here /admin/build/path/list) - that was root cause of the same symptoms for me. – user24581 Dec 18 '13 at 18:55
  • Are you sure, that you use correct token? For example car/[term:name] – Andrew Nov 17 '14 at 9:49
  • This is a terrible problem and I'm also stuck on it. You might want to start your search here: drupal.org/node/1847444 – coderama Jun 24 '15 at 14:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.