1

Formatting looks OK in input field using CKEditor but does not appear on page when published?

CKEditor is installed and working OK but the formatting is not applied to the published text

anything obvious I might be missing ?

2

If CKEditor is applying the styles correctly but the display of these styles is not showing up after a save, I think you may need to check out the 'Text format' you're using for that CKEditor profile. It should appear directly under the CKEditor in a drop-down.

enter image description here

After you see which text format you're using, check the configurations of that particular text format here: <your site>/admin/config/content/formats.

Make sure, when you check the settings, that the 'Limit allowed HTML tags' checkbox isn't checked, which may not allow certain html tags to be displayed. Look through all the options there and make sure there isn't something else that could be messing up your display.

Let us know if text formats end up being the issue.

|improve this answer|||||
  • Sweet! You can indicate that this answer solved your problem by marking it as 'accepted' - clicking on the check mark by the answer. No pressure, of course, just letting you know since you're a newer user. Glad it worked though! – Boriana Ditcheva Jul 31 '13 at 21:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.