I want users to participate in creating some content. I allowed them (people/permissions) to create own content on particular content type. The question is: how to provide them access to fields of content type, that are available to me as administrator? In other words, I can put content in fields through my admin panel, but how to make users possible to meet that fields, how to make fields public? Thanks in advance!

  • I didn't get the meaning of - 'but how to make users possible to meet that fields'. Considering, the content type is 'Hotel' & you want say, all the authenticated users be able to create content of type 'Hotel' and so associate data with the various fields, then you need to add permission 'Hotel: Create new content' by visiting 'admin/people/permissions'. If you need some role based permissioning, that you can control accordingly.
    – dhrubaj
    Commented Jul 29, 2013 at 6:11

2 Answers 2


By default, all the fields added to an entity are visible to every user who has permission to create or edit entities of that type. (In the case of nodes, the users needs the permission to create or edit nodes of that content type.) field_access() is the function that determines which users have access to a field, but Drupal doesn't implement hook_field_access().
If the field is not visible to the other users, check you don't have a module that implements hook_field_access(), such as the Field Permissions module. If you have one of those modules, check their settings.

Alternatively, there is a module that makes the field not visible to the users. Also in this case, check its settings or temporary disable it to see if the field is visible to any other user.

  • Thanks, bit still I don't see how to display empty field box to user. It should be like webform field. One page with empty fields, that users populate with information. How to make page that displays empty fields?
    – natttan
    Commented Jul 30, 2013 at 2:28
  • For example, as administrator I can create Content type, and if I want to add some content, I have to go to content/add content, then choose content type, and empty fields appears. My question is: how to make page page that displays empty fields for users to type into?
    – natttan
    Commented Jul 30, 2013 at 2:38

Give "Create content" permission to the user type who can create content at your instance.

There is the Field Permission module which lets you specify permissions for each field in a entity. You can set permission for each field by help of this module.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.