2

The usual region highlight (a dashed-line border around the region) with a little gear icon that opens up a drop down saying "Configure Block" is missing on my custom Drupal 7 site. Which or What admin option is responsible for this?

  • I am logged in an an administrator.
  • I have actual regions.
  • Those regions have data.
  • "Demonstrate Block Regions" shows where the regions are correctly.

How do I bring this highlighting back?

Contextual Links module is enabled.

This is my block.tpl-

<div id="<?php print $block_html_id; ?>" class="<?php print $classes; ?>"<?php print $attributes; ?>>
<div class="block-inner clearfix">
<?php print render($title_prefix); ?>

<?php print render($title_suffix); ?>

<div<?php print $content_attributes; ?>>
<?php print $content; ?>
</div>
</div>
</div>
2
  1. Make sure you have the Contextual Links module enabled.
  2. If you're overriding the default block template in your theme, make sure you're printing the $title_prefix and $title_suffix vars; I forget which one, but one of those contains the markup for the contextual links javascript.
  • I think I've printed those vars. Updated original question. – Samik Sengupta Jul 30 '13 at 13:11
  • 1
    Easy test - switch the default theme to Bartik temporarily. If the links aren't there, you don't have Contextual Links enabled. If they are there, something in your theme is broken – Clive Jul 30 '13 at 13:14
  • Contextual Links are enabled. I guess it must be something in the theme then? – Samik Sengupta Jul 30 '13 at 13:17
  • At a guess, yeah...but you can tell for certain if you enable Bartik temporarily – Clive Jul 30 '13 at 13:18
  • 1
    Ah, it should work in the admin area if you're using the 7 theme (unless it's altered of course). Do you have any JS errors in the console? – Clive Jul 30 '13 at 13:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.