3

I'm trying to get the Search API module to work on my Drupal 7 installation, but I get the following error when I go to Home » Administration » Configuration » Search and metadata » Search API » Default node index:

The server this index currently lies on doesn't support facets. To use facets you will have to move this index to a server supporting this feature.

What steps should I follow, in order to make my server compatible with the Search API module?

2
  • What search server are you using (MySQL Solr etc)?
    – googletorp
    Jul 29, 2011 at 13:55
  • i'm using mysql
    – matthewL
    Jul 29, 2011 at 14:10

1 Answer 1

4

You can't use facets on MySQL (for the moment), from the project page:

Search facets

This module provides the ability to create facets on any search executed anywhere in Drupal, be it a search page, a view or any other source. The feature isn't available for all servers, though, since it would be too complex to implement for some service classes. Right now only the Solr servers support this, facet support for the database-based searches might be done in the future.

This means that you can't use facets, but you can still use Search API to search your content.

14
  • oh so i need to install solr that's all ?
    – matthewL
    Jul 29, 2011 at 14:24
  • is it ok if i install apache-solr-1.4.1.zip ?
    – matthewL
    Jul 29, 2011 at 14:52
  • @matthewL What is described as "Solr server" is Apache Solr. It runs as Java servlet, and it requires a server like Tomcat, or other similar servers that runs as servlet container.
    – apaderno
    Jul 29, 2011 at 15:13
  • unfortunately i get same error even tho i sucessfully configured sorl, and apache solr module is configured perfectly and can communicate with solr on port 8080... not sure what to do now
    – matthewL
    Jul 29, 2011 at 15:26
  • 1
    @matthewL Did you install and enable the Search API Solr module? Did you copy the schema.xml and solrconfig.xml to the Apache Solr folder? Did you restart Solr one that was done?
    – Steven
    Jul 29, 2011 at 15:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.