1

I have set default download method in D7 to private. When uploading images, they are stored in the private folder (OS level). But when having a look to content-media, only a placeholder is visible. The image cant be displayed. Any ideas ?

Thanks

Martin

1
  • what does it say when you open the image in its own tab? 404,304? find the full path and try opening it in the browser then pls report back.
    – awm
    Mar 9, 2014 at 19:20

2 Answers 2

1

For the image to be displayed, you would have to have access to the private folder, but since you're an anonymous user to the webserver, it won't display.

Images being served on your website should be in a public folder. Downloads could come from a private folder if the webserver/Drupal moves them to a temp directory before downloading them.

3
  • I'm on MS IIS. To try, I set permission on file system level to Everyone=Read. No sucsess. Whats strange is, that the file lists in content view, but the click doesnt show it. Log shows correct private path: system/files/xxx.jpg. Public folder has problem, that once the path is know, you can access files without Drupal authentication.
    – user19044
    Aug 1, 2013 at 19:27
  • Actually when using private-mode, the transfer wont go via the webserver, but a php-get. So problably not webserver related.
    – user19044
    Aug 2, 2013 at 8:06
  • As Kevin noted, this needs to be stored on a public folder on your website. Permissions won't help anything if the directory is in an inaccessible area of your server.
    – rrr45
    Dec 11, 2014 at 17:46
0

Check fast 404 settings in your settings file...

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.