0

I am running a Zen subtheme for another drupal instance and it all worked fine. However, when I copied the folders across to my new Drupal instance, all I see is

The name of the site and

User menu :

My account
Log out

There is no Add content link... or the administration menu along the top... also no styles are applied... I am pretty sure I changed all the site specific instances in the code (.info file etc)... What am I doing wrong?

Ok, so I can navigate through the admin menu by changing the url path... admin/appearance

I have cleared the cache, but the styles for the zen sub theme are still not being picked up and I cannot see the Add Content link on the front page.

I've tried changing the theme to Bartik, and it looks fine. The styles are being picked up and everything.

So why is it not working for the Zen subtheme?

In the logs, I am seeing this message:

Notice: Undefined property: stdClass::$prefix in system_theme_settings() (line 547 of /home/mysite/public_html/modules/system/system.admin.inc).

Does this explain the wsod problem?

  • did you check whether you have blocks placed in regions ? theoretically the theme you had before could have had a different set of refions ... also, did you enable the zen theme ? – mojzis Aug 2 '13 at 0:18
  • 1
    Thank you @mojzis Enabling the theme based on the zen theme is the only thing I was able to do. All I now see is the chinese symbol, user menu and my account and log out links :S I can't even get to the blocks, because there is no administration menu... There is an administration menu on the drupal site I copied the theme and styles from though... SHould I have just started from scratch, by following the instructions in the zen folder, instead of copying an subtheme from another site? – user19417 Aug 2 '13 at 0:28
  • can you post your theme info file ? it could be that the reference to zen could be mistyped or something like that – mojzis Aug 2 '13 at 6:11
  • you might want to check the results of dpm(list_themes()); in devel/php under some other theme - look for zen and the prefix variable ... normally it contains "phptemplate" – mojzis Aug 2 '13 at 6:18
0

You need to copy over The Zen theme as well, A sub-theme requires both the sub theme and its parent theme in order for it to work

  • That's the thing that confuses me. I did also copy the zen theme as well @frazras – user19417 Aug 2 '13 at 1:13
  • Do other themes work? – frazras Aug 2 '13 at 1:15
  • They did... But I can't test if they still do, because I can't get to the admin menu :( I originally had the bartik theme selected, and it looked fine... @frazras – user19417 Aug 2 '13 at 1:21
  • Ok, so I can navigate through the admin menu by changing the url path... admin/appearance I have cleared the cache, but the styles for the zen sub theme are still not being picked up... and I cannot see the Add Content link on the front page... I've tried changing the theme to Bartik, and it looks fine... the styles are being picked up and everything... So why is it not working for the Zen subtheme? @frazras – user19417 Aug 2 '13 at 1:32
  • In the logs, I am seeing this message: Notice: Undefined property: stdClass::$prefix in system_theme_settings() (line 547 of /home/mysite/public_html/modules/system/system.admin.inc). Does this explain the wsod problem? @mojzis – user19417 Aug 2 '13 at 4:15
0

These are the steps you need to follow to use zen sub theme.

  1. Download the zen theme from https://www.drupal.org/project/zen and extract the zip file in to your "`sitename/sites/all/themes/"

now your theme folder will look like "sitename/sites/all/themes/zen" you zen base theme.

  1. move inside zen theme folder you will find STATRETKIT folder that is the sub theme you need to inherit, just copy that folder and paste it out site the folder

now in your themes folder you have two folder "zen" and "STATRETKIT" -> rename the folder to your desired theme name. lets say "samplesite"

  1. modify your info file name to "samplesite.info" please check if the file format is in .info or text file because in starterkit the info file is text you need to change the extention by saving it as info file.

  2. modify and create your css and js files as specified in the info file.

and if you have old site you want to copy that themes here dont copy full theme files here only replace the css and js file and your template.php and template folder alone.

  1. clear the cache in configuration -> performance . and check if its working.

if you have any issues still read this https://www.drupal.org/node/873778 installing zen

https://www.drupal.org/node/1549668 subtheme steps

Note: Always read the README.txt file for all modules and themes installation will help you install easily and understand quickly.

hope these steps will help

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.