3

My Drupal 7 site is upgraded from Drupal 6. When I install the Domain Access (not installed with Drupal 6) module, I need to rebuild permissions.

I tried rebuilding them from the administrative pages, but it fails; I tried doing it with Drush, but it failed again.

drush php-eval 'node_access_rebuild();'

I can't find any information in watchdog and PHP logs.

Does anyone know why it happens, or how I can fix this?

  • What indication do you get that it failed? Any messages at all? Or it just asks you to rebuild again? – rooby Jan 29 '14 at 10:25
  • @Rylyn did you get solution to this problem? – Sukhjinder Singh Sep 26 '14 at 16:57
  • Check apache/php error logs, usually you get no messages or watchdog log if the error caused you Application/Drupal website to stop before reporting it. if there is any issue you should be able to view it from the error logs. – mamoun othman Dec 23 '15 at 7:59
0

I was having a similar problem (Rebuild Permissions failing) and tracked it to Organic groups.

  1. Go to Administration > Configuration > Organic groups > OG field settings
  2. Under Bundles select the Group content type
  3. Under Fields select Group visibility
  4. Click Add field

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.