When I create a user view, I don't see the option for having hierarchical select on the exposed filters. I have the hierarchical data saved using hierarchical select already. Simple hierarchical select doesn't have the option too.

How can I create a user list hierarchical select exposed filter?

1 Answer 1


Hierarchical Select for Drupal 7 does not have Views support. At this point, the HS has not been actively maintained in more than a year so it is unlikely to expect this to be added soon, if at all. There is an issue on porting the D6 functionality to D7.

If using Simple Hierarchical Select, which only works on taxonomy terms, you can follow the instructions on the module's page:

  • add a new filter using the field set-up as "Simple hierarchical select" or use "Content: Has taxonomy terms (with depth; Simple hierarchical select)" as a new filter
  • use "Simple hierarchical select" as selection type
  • select "Expose this filter to visitors, to allow them to change it"
  • enjoy ;)
  • I am using using a user view so the 'Content:' option is not there...I have User:Location which is the field with the HS data. When I choose it I don't see any option to use SHS to display the exposed filter.
    – Jon
    Aug 14, 2013 at 13:28
  • Is the display widget for the field set to SHS to the field UI (under Manage Fields on the page for the content type)? Aug 14, 2013 at 13:40
  • I have tried that too but I still don't see an option to have filter displayed with SHS. I have the Selection type: Dropdown and Show hierarchy in dropdown box checked. Is this because its a user view and not a content view? Or do I need any relationships?
    – Jon
    Aug 14, 2013 at 16:00
  • If the field is on the user profile, you should be able to display it (you may need to change the formatter in the field settings within views). However, if the field is on the node, you will need to add a relationship to the nodes in question. Aug 14, 2013 at 16:29
  • I changed this the Formater but didn't help. Is the field related to the filter? I believe it should on Dropdown, and not Autocomplete, right? Should I post the view code here so you can see? Thanks for the assistant so far
    – Jon
    Aug 14, 2013 at 19:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.