0

I've just moved my drupal site from it's development server(just a VM on my home pc) over to it's new home, and all except the URLS are working.

I've setup the new server exactly like the development server, installed mod_rewrite, copied .htaccess, apache2.conf and httpd.conf word for word, yet, regardless of which page/node is displayed, the only thing in the URL is the domain name. And if I try to navigate to a specific node via the URL, it loads the front page instead of the intended node.

I'm not sure if this is related, but when drupal provides a link to a node, like the Welcome email for first time login, it uses the server's IP address in the URL, instead of the domain name.

Any help with this would be greatly appreciated!

Cheers,

Matt

  • Have you updated your settings.php file – 4life Aug 16 '13 at 13:21
  • Just the database name and login details to match the new server. Otherwise, settings.php is an exact copy from the dev server. Is there another setting in there that I'm overlooking? – matt Aug 16 '13 at 13:41
  • Is it possible that this has something to do with the way that I set up the domain DNS settings? As I don't know the first thing about that. I thought it would be as simple as pointing it to the server IP, but the options available(A, CNAME,MX...) were confusing and the descriptions weren't very helpful. Anyway, I found one that said "Forward to" so I entered my host IP address and saved. and since that seems to have worked, I haven't really looked any further into it. – matt Aug 16 '13 at 13:55
1

It sounds like with the 'Forward to' configuration for your domain, it may be iframed instead of the domain pointing directly to your server. When you type a direct url, the path isn't passed on to your actual site so it only serves the homepage, and when you click on links it only changes the url of the inner frame so the address bar doesn't update. You can check if the page is actually in an iframe by viewing the source of the page.

For setting up the DNS, you should be creating an 'A' record to point the hostname directly to your IP address.

  • Yeah, thanks man. I edited the DNS settings and it's working perfectly now. – matt Aug 16 '13 at 17:13
0

It looks like my domain settings were the issue. I updated them after reading up on the configuration, and URLs are working perfectly

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.