I have a taxonomy vocabulary of universities with their parent states. I then added this taxonomy field to the user profile so I could indicate what university the person was from. I'm trying to get this taxonomy vocabulary to display in an jump menu in a view (Drupal 7, Views 3) and honor the parent hierarchy, but the child/parent relationship is not being honored. This is how my jump list looks:

    University of Georgia
    University of California

I'd like it to look like this:

    --University of California
    --University of Georgia

I've read many possible solutions that suggest to add, "Taxonomy: Terms on node," but I don't even see that as an option. Any help would be greatly appreciated.

1 Answer 1


You need to add "Content: Taxonomy terms on node" as a relationship.

enter image description here

enter image description here

  • "Content: Taxonomy terms on node" is not a option from which I can select in Relationships. Any idea why?
    – John
    Aug 21, 2013 at 15:41
  • Your view is built on nodes correct and not users? Aug 21, 2013 at 15:45
  • No, the view is based on users. The taxonomy is associated with users, that's why the jump list shows the taxonomy terms and the users who have that taxonomy term.
    – John
    Aug 21, 2013 at 15:49
  • Any way to do this when it's based on users?
    – John
    Aug 21, 2013 at 16:24
  • I created a user view after adding a vocabulary (with multiple levels) to my users and was able to get the terms from "User: FIELD", where field is whatever you called the field. Aug 21, 2013 at 16:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.