I would like to be able to import content from CSV using Feed. My content type are like this : -Titre

-Field Collection :

--Name (simple text)

--Term (Term reference of type Autocomplete term widget (tagging)

For begin able to import field collection i have applied the #16 patch https://drupal.org/node/1063434#comment-5217400

Everything is working fine exept the insert of my Term field in my fieldcollection because is it of type Autocomplete term widget and if its a new term. I want to keep this type of widget because i want to be able to create new term if they doesnt exist already. I confirm that if i enter a existing term value for my Term field in my csv, my term is succesfuly added.

I am using :

Feeds : 7.x-2.0-alpha8+7-dev

Feeds Tamper : 7.x-1.0-beta3+56-dev

Field collection : 7.x-1.0-beta5

I dont know what i have missed... i am lost and blocked on this bug since 2 weeks.

I hope someone will help me,

Best regards


1 Answer 1


A couple of things.

  1. You are using a very old patch. In my implementation I am using the one in #102 (I see its now up to #119) https://drupal.org/node/1063434#comment-7395840

  2. You need to tell feeds that it is ok to create new terms for you. Once you've added the target in Node processor > mapping for the term reference you can change it's target configuration (the cog icon). There is a checkbox there 'Auto create'

[edit] Please use the new patch in #121 https://drupal.org/node/1063434#comment-7792223 which corrects your issue.

  • Hello Queenvictoria, I have tested the new patch and nothing changed, i also have correctly checked Auto create in my mapping field conf. Have you tried my configuration, insert term reference with auto complete in one field collection ? It doesn't work for me. Aug 24, 2013 at 11:53
  • Hi Jerome. I've tested your method and agree that it doesn't work. As such I've created a new patch that corrects the issue. Its at #121 drupal.org/node/1063434#comment-7792223 Aug 25, 2013 at 20:22
  • Hi Queenvictoria, I confirm that your patch if working perfectly. Really big big thanks ! Aug 26, 2013 at 17:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.