0

After much searching online, I can't figure out why my "search" block is not showing up on every single page of my website. I went to the configure screen for the block and ticked the "All pages except those listed" radio button and didn't list any pages in the field below. So that should make the block appear on every page of my site, correct? That's not the case, however; there are a handful of pages, most of which are "views" (i.e., the page shows a series of tabs -- View, Edit, etc.) where the block simply doesn't show up. Am I doing something wrong?

  • Does the region in which the block renders exist on those pages? – Letharion Aug 24 '13 at 18:27
  • Thanks for your response, Letharion. I'm still relatively new to Drupal -- how can I tell if a region exists on a page? – Drupguy Aug 24 '13 at 19:22
  • I'm not a big fan of the blocks/region system, so I don't know what's the best way. I suppose looking at the markup on pages where the block does show up would give hints, I don't have anything more concrete than that. – Letharion Aug 24 '13 at 19:47
1

I think you have got issue with the rendering of that particular region into the page.tpl.php, where this block doesn't show.

Follow this steps to identify the issue --

  • Find the machine name for the region where you are putting your block from the THEME.info file.
  • Open your all page*.tpl.php file in the theme one by one. May be your theme contain different page.tpl.php for different kind of content display. If it not done by you then this step can be hectic as sometimes we declare the custom page.tpl.php structure in template.php too. But initially you can check all the TPL files starting with page.
  • Check for the rendering of the content by searching the machine name which you have got in .info file for the region where you are placing the block. I think somewhere it's not rendered.
  • Render the region into the TPL file where it is not. Clear the cache & check you display.
  • Thanks for your comment, RajeevK. I tried your method but couldn't make any headway, so I went ahead and looked at the panel itself, and realized I'd ticked the "Disable Block" checkbox for those particular pages. So when I un-checked it, the search block returned. Thanks again Letharion and RajeevK for your insights. – Drupguy Aug 26 '13 at 3:39
  • Aah panel, totally forget.. – RajeevK Aug 26 '13 at 5:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.