1

This error showing when I tried to import a CSV file on my live site. Same file I tried in local site working fine.

Cannot acquire lock for source node / 0.

The modules I am using are the following:

  • Feeds
  • Feed Excel
  • Libraries (PHP Excel)

I examine the issue and found that the error occurred when I tried to import an image. Have anyone faced this issue?

  • Hello. Could you add info about modules you are using? Drupal does not provide CSV imports or node locks in core. – Mołot Aug 26 '13 at 6:58
  • As side note, there isn't any Drupal node whose node ID is 0; the lower node ID is 1. – kiamlaluno Aug 26 '13 at 7:02
  • updated my question. – Sumit Madan Aug 26 '13 at 7:02
  • @kiamlaluno Its working fine in local site. I didn't set node id also. I am creating new node. – Sumit Madan Aug 26 '13 at 7:06
  • Is there a node id 0 in your database? It is possible to create it directly and it can screw up pretty many things. Like @kiamlaluno said there can't be a valid node with that ID, but database would allow it none the less. – Mołot Aug 26 '13 at 7:08
2

To release the lock, remove it from semaphore table, e.g.:

drush sqlq "DELETE FROM semaphore WHERE name LIKE 'feeds_source_%'"

If you got different error like:

The feed is currently importing.

then you need to clear out state and fetcher_result data from feeds_source table, e.g.:

drush sqlq "UPDATE feeds_source SET state = NULL, fetcher_result = NULL WHERE id = 'FEEDS_MACHINE_NAME' AND feed_nid = 'NID'"

Note: Change FEEDS_MACHINE_NAME and NID into appropriate values.

1

Image path was not correct so the error was showing.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.