2

I am having multilingual site in drupal 7. I have a content type that should be translated in 2 languages, I am using term reference field in it, with display type select list

First I tested
Localize. Terms are common for all languages, but their name and description may be localized. and
Translate. Different terms will be allowed for each language and they can be translated
But in any language, all terms from all languages are shown in the select list,
Then I decided to use
Fixed Language. Terms will have a global language and they will only show up for pages in that language.
and use separate vocabulary per language but when I want add a node in second language or translate english nodes in second language(persian) show the first language (english) terms only.
How can I achieve this job ? I want to show terms only from current language.

Edit again I came back to using one vocabulary and I have this problem
enter image description here
and my vocab and translations
enter image description here

and when I am in english site show perisan terms :( enter image description here

why does this happen? and what is the solution ?

2

I had the same problem. I enabled 'Synchronize translations' (i18n_sync) module. This solved it. It is bundled with i18n module.

https://www.drupal.org/project/i18n

0

If I understand you correctly - 1. Multilingual site (3 languages) 2. Taxononomy Goal - when in language 1, show taxonomy terms in language 1. When in language 2, show taxonomy terms in language 2.

I think it is Check Translate. Different terms.... When you enter a new taxonomy term, you will need to put it in three times using the translate button that appears next to edit when you display the taxonomy term.

When the user chooses a language, then the correct taxonomy terms should appear.

I hope this step-by-step helps you see the structure.

  • This didn't help me to solve the problem. – jiv-e May 8 '14 at 16:29
0

A bit old question but i just came across because i had the same problem. Selecting "Translate. Different terms will be allowed for each language and they can be translated." when you create your vocabulary seems the right option BUT IS NOT!

You have to select "Localize. Terms are common for all languages, but their name and description may be localized." to your vocabulary settings. Then when you add a new term (e.g. in English) you have to select "Save and Translate" at the end of the form.

That worked for me :)

0

You can try using the Entity translation module with the Title module instead of taxonomy translation (i18n_taxonomy).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.