2

After issuing the following command in the base drupal folder (/var/www/html)

$ drush status

I get the following response.

PHP Fatal error:  Cannot redeclare libraries_drush_command() (previously declared in /var/www/html/profiles/commons/modules/contrib/libraries/libraries.drush.inc:13) in /var/www/html/sites/all/modules/libraries/libraries.drush.inc on line 25
Drush command terminated abnormally due to an unrecoverable error.                                                                 [error]
Error: Cannot redeclare libraries_drush_command() (previously declared in
/var/www/html/profiles/commons/modules/contrib/libraries/libraries.drush.inc:13) in
/var/www/html/sites/all/modules/libraries/libraries.drush.inc, line 25

This is a new server install using RHEL 6.4 (Santiago) and drush 6.0 installed through pear.

Where I might begin to fix this?

  • 1
    You've got two copies of the libraries module, one in profiles/common and one in sites/all - interestingly both are being included in the page load which suggests they're both installed somehow. Is this just a stock install of Drupal Commons? – Clive Aug 28 '13 at 19:05
  • This is version commons 3.3. I may have to let them know... – Rick Aug 28 '13 at 19:21
1

Removing /var/www/html/sites/all/modules/libraries/libraries.drush.inc cleared things up. I bungled things up somewhere. IRC #drupal-commons confirmed Clive's note above.

  • Make sure to mark your answer as complete. :) – kyletaylored Aug 28 '13 at 23:04
  • I intend to mark it; however, there is a 2 day waiting period that must pass before I can. – Rick Aug 29 '13 at 1:57
  • I ran into the same issue, after redeclaring libraries module, it had some problem with features module as well, I assume this issue happens if you are using drupal profiles and there's duplication of modules in /profiles/PROFILENAME/modules/contrib/MODULENAME and also in /sites/all/modules/MODULENAME – Sohail Oct 12 '13 at 7:57
0

Drush seems to load duplicate command files as reported in https://github.com/drush-ops/drush/issues/280 and looks like the they fixed the same https://drupal.org/node/644126

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.