1

I'm using Drupal 7 and Webform Module for create contacts forms (This problem also what I have in Pressflow 6).

Only authenticated users can send mail through the form. However, I need that anonymous users can also use the form.

The error is as follows:

Error sending e-mail from sender@email.com to target@mail.edu.pe: SMTP Error: Data not accepted.
SMTP server error: 5.7.1 Sender domain not allowed.

How I can make the form send mail with both roles (authenticated and anonymous)? How I can avoid spam for users anonymous?

Details

Each time you use the contact form (either anonymous or authenticated) to send an email to the person responsible of receiving these emails.

1

Anonymous users can absolutely submit webforms. On the Form Settings page under submission access, there are permission checkboxes for each role. You can use Captcha or Mollom to help prevent spam submissions.

Role permissions for webform.

The error you're having seems like you have SMTP misconfigured. Are you currently using the SMTP module? If so, run a test to send an email to yourself. If that fails, then it's definitely the problem.

| improve this answer | |
  • Yes. I have SMTP module. I run a test to send an email and the result is OK. My SMTP module is correctly configured. The error only appers with anonymous user. – Dvex Aug 29 '13 at 17:13
  • In form settings I have the 2 roles checked. – Dvex Aug 29 '13 at 17:14
  • Try turning off the SMTP module, clearing cache, and then submitting a form as an anonymous user. I'm not saying this will fix it, but I really don't think it's an issue with Webform. – kyletaylored Aug 30 '13 at 4:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.