1

Looking through recent log messages, I've got a number of errors with no referrer listed, and showing location as being http://default/index.php (instead of http://mysite.com/some/page). They all seem to be triggered by "Anonymous" from localhost (127.0.0.1). Example screenshots are below.

Anyone know what kind of sense I should make of these entries?

Example screenshots: enter image description here

enter image description here

Here's one where location is not http://default, but http://localhost... again, why?

enter image description here

4
  • Are you runing cron via drush? http://default is the site uri drush will use if no one is provided. – jonhattan Aug 29 '13 at 22:48
  • @jonhattan: I AM running cron via drush, and suspect you put your finger on the source of my confusion. Do you have any idea about that last screenshot (which I just added), whichere location is not default, but http//localhost ? – Jordan Magnuson Aug 30 '13 at 21:43
  • It seems unrelated. Do you use localhost to access the site with the browser? This may explain that simply a file was not found. – jonhattan Aug 31 '13 at 10:12
  • @jonhattan: do you want to submit an answer (regarding drush cron) so that I can mark it as correct? – Jordan Magnuson Sep 2 '13 at 20:01
1

http://default is the site uri drush will use if no one is provided.

To provide a site uri you can pass options -l or --uri to drush: drush -l http://example.com cron.

Otherwise you can define and use an alias. See drush example for reference. In a scratch:

File /etc/drush/aliases.drushrc.php:

<?php

$aliases['sitename'] = array (
  'root' => '/var/www/sitename',
  'uri' => 'http://example.com',
);

So the command to run is drush @sitename cron.

1
  • Thanks jonhattan. I was running cron via drush, and this turned out to be the reason for the http://default location in my watchdog messages, in my case. – Jordan Magnuson Sep 4 '13 at 16:16
3

The first error seems to be due to a failing operation with the Backup & Migrate module. This module is probably configured to make a backup of your database on a scheduled (CRON) interval. As the error message suggests, increasing PHP's max_execution_time setting may help.

The second error you're seeing is due to a missing 'type' column in the file_managed database table. This field is usually added by the Media and/or File Entity modules. You likely updated these modules' code, but didn't run updates. Try running your update.php, or if that fails, disable, uninstall, and re-install the Media and File Entity modules.

1
  • Thank you for the feedback Yuriy: much appreciated. Though my main question was not the source of the particular errors, but why I was seeing http://default as the location. – Jordan Magnuson Sep 2 '13 at 19:26
2

I would guess that your server is not set up for virtual hosting. If it receives an unqualified http request, it will go to the default, finding, in this case, index.php in your webroot. Since it is a direct request, there will be no referer. There is no DNS lookup necessary for local tasks. These messages are probably being kicked out by a cron or batch job.

I would not be concerned. But you certainly should address the missing column in the PDO exception.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.