2

I have a standard Drupal 7 installation with the i18n module and 3 languages defined.

  • one basic page "node/1" created with the URL alias "home"
  • in the Configuration > System > Site Information the default front page is "home"
  • created other 2 languages (pt-br and it)
  • created the translation of the basic page "node/1" to pt-br and it (are created "node/2" and "node/3" pages)
  • the 3 pages "node/1, 2 and 3" have the same alias "home"

If I go to mysite/en, I see the defined front page in english and all the site is in english: it's ok!

The problems:

  1. If I go to mysite/pt-br/home, I see the site in portuguese and the "node/1" in porguguese: it's ok!

  2. If I go to mysite/pt-br, I see the site in portuguese but the "node/1" content in english and not the "node/2" (portuguese version of the basic page): wrong!

  3. the same thing to the italian version.

What is wrong? How to set the correct language node for front page in the default language url (mysite/pt-br and mysite/it)?

Note: In the Detection and Selection tab is the original items with the default order (URL, Session, User, Browser and Default) and I have been enabled all (in the Configure page of URL the selected option is the Path Prefix).

  • What have you selected in admin/config/regional/language/configure? – Kari Kääriäinen Sep 1 '13 at 17:39
  • In the Detection and Selection tab is the original items with the default order (URL, Session, User, Browser and Default) and I have been enabled all. (in the Configure page of URL the selected option is the Path Prefix) – Eduardo Leggiero Sep 2 '13 at 6:30
  • 1
    Enabling all of them makes it really hard to figure which ones are effective. Try just the URL first (with default). – Kari Kääriäinen Sep 2 '13 at 9:53
1

Make sure to declare your home page node as a "multilingual varialable". For more details on these kind of variables, and how to get this to work, refer to my answer at How to make content translation available for front page?.

I'd be interested to some day hear if this resolved the issue here.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.