1

I recently upgrade my Drupal6 site to Drupal7 and migrated to getpantheon platform, I am hand-coding absolute image url's in nodes like this :

<div align="center">
<img src="http://www.megaleecher.net/sites/default/files/images/sneaksy.jpg"
style="max-width:100%;height:auto" alt="sneaksy" />
</div>

Despite using full absolute url's, images in feedburner are getting broken : http://feeds.feedburner.com/TheBestInternetNews as it's source http://www.megaleecher.net/rss.xml is outputting relative images.

Strangly, using $base_url = 'http://megaleecher.net'; (without www) in settings.php fixes the issue but using $base_url = 'http://www.megaleecher.net'; (with www) makes them relative again.

I have hired two drupal dev's from oDesk (https://www.odesk.com/o/jobs/job/Fixing-relative-image-paths-Drupal-rss-feed_~~0c48e61824bc3263/) and also asked for support from getpantheon but no solution.

2
  • What tool are you using to output rss?
    – Mołot
    Sep 3 '13 at 7:43
  • @Mołot I am not sure what you intended to ask, I am using Drupal7 global feed and no additional module is being used to modify that. Sep 4 '13 at 2:43
1

Disabling CDN module did the trick, even when not enabled for images the module still made image path's relative resulting in broken images for feeds. Posting the issue on CDN module issue queue.

1

Module Pathologic might help your problem, if you haven't tried that. Here is a quote about it (from the module's project page):

... is an input filter which can correct paths in links and images in your Drupal content in situations which would otherwise cause them to “break;” for example, if the URL of the site changes, or the content was moved to a different server. Pathologic can also solve the problem of missing images and broken links in your site’s RSS feeds.

Pathologic is designed to be a simple, set-it-and-forget-it utility. You don't need to enter any special “tags,” path prefixes, or other non-content noise into your content to trigger Pathologic to work; it finds paths it can manage in your content automatically.

1
  • already tried that, strangely it is also having no impact on output !! Sep 4 '13 at 2:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.