0

I have a site built on Commerce Kickstart 1 - Views 3.7.
I have a standard cart, to which I wanted to add photos of the products. It is a view that includes a relationship to Commerce Order: Line items and a contextual filter by Order ID.

Now, I added a reference to the product in order to be able to access the photos. The view works OK, all the initial elements and the images are there, but when i try to edit it, all the relationships are gone and I receive the "This view has been automatically updated to fix missing relationships" message. Both the relationship I added and the default relationship to line items are gone.

RELATIONSHIPS
Commerce Order: Line items
(Line Item) Commerce Line item: Product

FIELDS:
(Line Item) Commerce Line item: Display path
(Product) Field: Image (Image)
(Line Item) Commerce Line Item: Title
(Line Item) Commerce Line item: Unit price
(Line Item) Commerce Line Item: Quantity text field
(Line Item) Commerce Line item: Total
(Line Item) Commerce Line Item: Delete button

To me it looks like a bug in Views? There is a discussion of a similar issue https://drupal.org/node/1860380 (the last post is actually mine). Maybe I am wrong, though, maybe it's me who's doing something wrong?

  • 1
    Could well be a bug in views - but that would preclude us helping here, as bug reports need to be kept in the module issue queue. Could also be a bug in Kickstart; version 1 is unsupported by the looks of things - time to upgrade to Kickstart 2 maybe? – Clive Sep 3 '13 at 12:58
  • Well, but maybe the someone had similar problems? And CK 1 seeems still supported - new versions appear. I like it more then CK2 because it's closer to plain Drupal. – Dalmaz Sep 3 '13 at 13:15
  • 2
    To help with your debugging: you need to narrow down which of the modules you have installed is causing the problem. Start a blank install of Drupal, adding one module at a time, and see if you can reproduce the problem. Keeping adding modules until you've re-built your site up. At that point you'll either know what module is broken, or it'll work, and you'll know it was a configuration issue first time round. – Clive Sep 3 '13 at 13:22
  • 1
    @Clive Thank you for debugging tips. I did test whether it's maybe a php 5.4 ot Internationalization problem - tried to run it on php 5.3 server and witout i18n module. Nothing changed. – Dalmaz Sep 3 '13 at 15:24
  • 2
    Yes, a debugging night in view (Views?). Moving stuff around from a place my grandmother used to live, i found a bottle of brandy from Yougoslavia (!), year 1971 (!). It will keep me company on that one (with moderation, of course)! – Dalmaz Sep 3 '13 at 15:47
0

EDIT: It turned out after all that this behaviour was related to the "Administration Language" module https://drupal.org/project/admin_language‎.
Disabling it made the problem disappear for good.
It seems as its is related to access permissions. A similar problem was encountered in creating product views in drupal commerce. If you want to relate to the fields of the referenced product, you have to grant the View permisssion to all products (non-node enitities of DC). Otherwise the users without permission to view the product enitities will see an empty view (see Views results empty for unprivileged user when using Relationship: Content: Referenced Product). What makes it especially difficult to track that the problem does show up only when one uses Relationship & "Fields" display. A similar view with content / teaser etc renders the same content without problems.

Now, I wanted to add an image of the product to the cart view. I referenced the Image field of the product in the cart ((Line Item) Commerce Line item: Product), and put the image field from there.

I understand that the permissions problem prevent the view from functioning properly. It seems to be that it's a bug that
a) the view itself functions well
b) that the problem appears in the Views UI
c) that the error message is not informative.

It seems to me that this behavior is just a side effect of a number factors in how the Views work.

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.