0

I have a few crons set up to run every 15 min. My system cron is set to execute every 5 mins. However one cron keeps getting stuck in the (w) state. I updated its setting to run every minute (* * * *) and still every time the cron run all jobs get executed except for one homepage_extensions_cron (w) - [run] * * * * * 09/06/2013 - 15:14 7s 4 3s / 7s This is really troubling me.

When I run the cron manually ( replicating what the system is doing) the cron runs fine. I do it through curl. When I execute the curl through command line, the task runs. I am suspecting there is some timing tricky stuff here. Can someone please explain how this work? Also, I am trying to clear a certain cache id in the cron task and do an http request. Could this cause an issue?

2

The "(w)" flag means only that the job is ready to be executed (waiting for the system crontab to start and execute it).

If a job has a rule like "* * * * *" (= execute it EVERY minute), it's quite normal that the "(w)" is always on.

If you use a rule like "* * * * *", assure that system crontab is set to "* * * * *" too. That way you minimize the (w), because system crontab runs every minute too and executes the job as fast as possible.

(However, a little time with (w) is normal and not to be considered a problem).

0

Ok, the problem was not with elysia cron but rather with our over-engineered system. The cron runs on a different box that did not have the uptodate code. Therefore, when I visited the UI, I was able to see the cron because I am connected to a certain box the load balance designates (again some over-engineered stuff). We synced the code using cfenging and now the cron is recognized and runs.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.