0

I am attempting to perform a multisite installation. My main (presently working) site is located in a subdirectory called "beta" of my ~/public_html folder. This is the site for jackstahlco.com and it is working. I also want to have this installation of Drupal run two other sites.

The first other site I am trying to get to work is meadowlarknm.com. This site is presently resolving to jackstahlco.com, which is NOT correct. I created ~/public_html/beta/sites/meadowlarknm.com/ and ~/public_html/beta/sites/meadowlarknm.com/files. I copied default.settings.php into meadowlardnm.com/ and changed the permissions, as well as creating a 'files' directory. The settings.php also contains

$databases = array ();

and no other database configuration.

When I navigate to www.meadowlarknm.com, I just see the www.jackstahlco.com website, instead of the Drupal installation screen that I expect. You can go there to see what I'm talking about, unless I fix this problem immediately after writing this question.

I am suspecting that this may be a .htaccess issue, but I am not sure. It's a little bit weird that I am trying to run multi-site from a subdirectory, but it seems like this should be possible (if my understanding was complete.)

Here is my .htaccess (inside ~/public_html, I did NOT change the .htaccess inside ~/public_html/beta):

########## End - Rewrite rules to block out some common exploits

#  Uncomment following line if your webserver's URL
#  is not directly related to physical file paths.
#  Update Your Joomla! Directory (just / for root)

# RewriteBase /

RewriteCond %{HTTP_HOST} !^www\.jackstahlco\.com$ [NC]
RewriteRule .* http://www.jackstahlco.com/      [L,R=301]
RewriteRule ^$ beta/index.php   [L]
RewriteCond %{DOCUMENT_ROOT}/beta%{REQUEST_URI} -f
RewriteRule .* beta/$0 [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule .* beta/index.php?q=$0 [QSA]
#
#RewriteCond %{HTTP_HOST} ^(www.)?jackstahlco.com$ [NC]
#RewriteRule ^(/)?$ /beta/$1 [L]

RewriteCond %{HTTP_HOST} ^(www.)?jackstahlcompany.com/puertadelsolsite$
RewriteRule ^(/)?$ puertadelsolsite [L]


RewriteCond %{HTTP_HOST} ^meadowlarknm\.com$ [NC]
RewriteRule ^(.*)$ http://www.meadowlarknm.com/$1 [L,R=301]

########## Begin - Joomla! core SEF Section
#
#RewriteCond %{REQUEST_FILENAME} !-f
#RewriteCond %{REQUEST_FILENAME} !-d
#RewriteCond %{REQUEST_URI} !^/index.php
#RewriteCond %{REQUEST_URI} (/|\.php|\.html|\.htm|\.feed|\.pdf|\.raw|/[^.]*)$  [NC]
#RewriteRule (.*) index.php
#RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization},L]
#
########## End - Joomla! core SEF Section
<IfModule mod_suphp.c>
 suPHP_ConfigPath /home/jsco
 <Files php.ini>
   order allow,deny
   deny from all
 </Files>
</IfModule>

Additionally, the following is in /home/jsco/public_html/beta/sites/sites.php:

  $sites = array(
   'www.jackstahlco.com' => 'default',
   'www.meadowlarknm.com' => 'meadowlarknm.com',
  );

The end goal here is to re-do the existing sites on this server (some Joomla! as you may have guessed from the .htaccess) to a single Drupal system running multisite.

I don't believe this is a DNS issue. nslookup says these are all going to the correct place, and my domain-to-folder mapping on cPanel (sending everything to ~/public_html) looks OK.

Additionally, the multisite wizard says MOST of my steps are OK.

OK Create sites/sites.php file
OK Fill up sites/sites.php file with domain-folder array
OK Create sites folders inside sites/ folder
OK Each site folder should have own settings.php file
NOT OK - Prefix inside each settings.php file should be unique. I think I want a different DB

Thank you very much for the help.

-Brian J. Stinar-

3

Indeed this is not a DNS issue, the problem here is your sites directory is located in the wrong directory. It shouldn't be under all but in the root of sites. In your case it should be:

sites/jackstahlco.com/settings.php
sites/jackstahlco.com/files
sites/meadowlarknm.com/settings.php
sites/meadowlarknm.com/files

If you want the Drupal installation process popping up, you need to put an empty array connection info in the settings.php of the desired website.

$databases = array ();

The sites.php should be like this:

$sites = array(
    'jackstahlco.com' => 'default',
    'meadowlarknm.com' => 'meadowlarknm.com',
);

You don't need to specify the www prefix.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.