0

I have months old problem of missing "Save" button on the user account edit form. Which is annoying to the point that now I have to find the solution.

I don't usually use account edit form since there is only one user. I have updated many modules and different cores but problem always remained there. Right now I am running latest core which is 7.23. And all modules are updated. This is a multilingual website.

Since this problem has appeared I am unable to save any change in any user account. Please have a look on the image attached. Please help.

Thanks. enter image description here enter image description here

9
  • right click and click on the inspect element and see the properties for submit button exists ?
    – harshal
    Commented Sep 15, 2013 at 16:19
  • Thanks @harshal for input. I have checked the html of the user account edit form. I have not found the div for the save button. Which is simply not generated. Have a look [i.imgur.com/yafZGjA.jpg]
    – Monsoonpk
    Commented Sep 15, 2013 at 17:09
  • What do you mean by "there is only one user"? You have several roles and Masquerade module and you also say "I am unable to save any changes in any user account". Commented Sep 16, 2013 at 0:50
  • @KariKääriäinen Previously I had some dummy accounts from the beginning of the project which I deleted later on. They also did not have save button on their account edit form.
    – Monsoonpk
    Commented Sep 16, 2013 at 14:13
  • What else could this be than a bug in some of the contrib modules? I was looking into ways of printing the form state at all relevant hooks by hacking core, but didn't come up with anything practical. Looks like you're gonna have to just disable modules until you get your button back. I would try to use some kind of a forking scheme, disable first half, then half of the rest etc. Maybe make a copy of the site file system and database or take a backup and restore that later. Commented Sep 19, 2013 at 19:45

1 Answer 1

0

Try disabling i18n synchronization module.

There is another question similar to yours. Save button missing from content type edit form Problem: save button missing from content type edit form. Reason: bug in i18n synchronization module. Solution: none here, but...

There is another case where i18n synchronization causes an infinite loop and there is patch along the lines of

if (function_exists(i18n_sync)) i18n_sync(FALSE);

This is the link, the patch is at #3. https://drupal.org/node/1372500 Maybe that will help you to the right direction.

3
  • thanks for very useful points. I have read these posts before. I have disabled i18n synchronization module, cleared the caches ran update.. still no Save button on the account Edit form..
    – Monsoonpk
    Commented Sep 15, 2013 at 23:48
  • Can you create a non-admin user and see if it has the same problem? Commented Sep 16, 2013 at 0:32
  • yes, I have created non admin accounts and still no luck. thanks for help.
    – Monsoonpk
    Commented Sep 16, 2013 at 14:16

Not the answer you're looking for? Browse other questions tagged or ask your own question.