0


I have installed the CKEditor module, the CKEditor library and the CKFinder library.
I have modified correctly the file config.php and the file settings.php, but when I want login in my site, I don't get the permission for access. If I comment the variable cookie_domain I can access at the site and all working properly, but I get a message error that say: "You are using a feature that requires $cookie_domain to be set, but it is not set in your settings.php file (CKFinder is enabled in the Advanced profile)". What can I do?

1 Answer 1

1

set the $cookie_domain variable in sites/default/settings.php

<?php
$cookie_domain = $_SERVER['SERVER_NAME'];
?>

Uncomment the $base_url variable and set the base URL of your website (without the trailing slash).

Another option if you have the Drupal Domain access module installed use

<?php
$base_domain = explode('.', $_SERVER['SERVER_NAME']);
unset($base_domain[0]);
$base_domain = '.' . implode($base_domain, '.');

$cookie_domain = $base_domain;
?>

Here is the reference to the answer

1
  • I have already uncomment the $base_url and I have set the base URL of my site. I'll try your option for the $cookie_domain
    – erarklin
    Sep 19, 2013 at 8:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.