I'm using Drupal 7 on an Ubuntu VPS, I'm trying to setup CDN module with Rackspace cloud files. I'm using file conveyor and the whole setup going well. the only problem I have that Drupal CDN module not altering the files url to use the cdn urls. it still use local files. - the files already synced to rackspace. - file conveyor working fine. - Drupal CDN configured correctly and it show me that it sees file conveyor working and it's sees the sync file database.

  • more details about the issue: I'm using multisite setup and I'm using file conveyor with the public files folder.

Any Advice? Thanks

  • Is it all the files? Or just some? Like do your CSS/JS not work, but images do? Have you cleared your cache?
    – Steven
    Sep 20 '13 at 16:52
  • yes cache cleared, and no files came out of the cdn. I'm using the cdn files for the public files folder not everything
    – sam2de
    Sep 20 '13 at 17:29
  • How are you making the URLs? Manually or file_create_url()?
    – mpdonadio
    Sep 20 '13 at 23:13
  • I don't have any custom modules or files yet, but I'm on any file stored in the public files folder. like an image in the image field : /sites/mysite.com/files/styles/medium/public/field/image/imagefield_c3ayN8.jpg
    – sam2de
    Sep 21 '13 at 2:25

I suspect you have a setting or two wrong. On admin/config/development/cdn make sure you are enabled, and not in testing mode:

enter image description here

Then goto admin/config/development/cdn/other, expand all of the sections and make sure you aren't excluding actual pages.

  • Yes , these are correct, CDN Enabled and nothing excluded
    – sam2de
    Sep 20 '13 at 17:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.