A little background on the problem: I have been tasked with figuring out a problem in a Drupal site that I have no experience with. I have done Web Development using PHP, etc. but never used Drupal. I have a parent site with 3 sites underneath, and roles for each user (can be members of all sites or just one). I have a rule that sends an email out to these users after certain content is submitted. However, not all of the users receive the emails (about 150-180 users per email blast).

Does anyone have suggestions as to how I can go about debugging and figuring out this problem? I have to fix this by tomorrow. Here is what I have done so far:

-Made sure users were assigned to the role in the email rule. -Unchecked the box "send only to active users"

Any help is appreciated!

  • it's likely all of the emails are being sent by the server and go missing in transit. You would be better off sending your emails through a service rather than from your server. – Scott Joudry Sep 26 '13 at 17:42
  • Thanks for the reply. Do you have any suggestions on email services to try out? – Landon Sep 26 '13 at 17:52
  • mailgun.com, postmarkapp.com, mandrill.com - any email provider that does transactional email wil work. There are a ton. upaknee.com is a good Canadian solution if you're in Canada. You'll need to contact them regarding transactional email. – Scott Joudry Sep 26 '13 at 17:56

Default PHP mailer has a lot of issues, and sometimes mails are not received or accepted by the servers as this a common method for sending spam.

A good practice is to use the SMTP module (https://drupal.org/project/smtp) for sending emails. You need to connect it to a server (eg. google) for authentification and then it replaces the default drupal php mailer.

| improve this answer | |
  • This is another option, probably better than using a service. – Scott Joudry Sep 26 '13 at 22:52
  • Thanks @Neograph734. I tried to vote up your answer but I don't have enough rep....I will try to do this and let you know how it goes. – Landon Sep 27 '13 at 16:31
  • I see you marked this question as answers already. So I assume it worked :). – Neograph734 Sep 28 '13 at 17:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.