4

I have a multilingual drupal 7 site.

I want to translate my description metatag of my English frontpage version of my site. Any other page show ok in site Greek and English.

The problem is it only show the Greek version.

I have i18n and metatag module.

What i have try is to navigate to en/admin/config/search/metatags/context and add my English url (www.mysite.gr/en) so i can add manually the description there. But it didn't worked.

4

All major translation issues for metatag module are now fixed (see: https://drupal.org/node/1282620, https://drupal.org/node/1688286)

All you have to do is:

  1. Go to metatag settings page: /admin/config/search/metatags
  2. Override your frontpage (/admin/config/search/metatags/config/global:frontpage) and write your infos in default language
  3. Save your modifications
  4. Go to your homepage
  5. Flush site cache
  6. Switch site language for every other language (this way all strings can be generated for translations)
  7. Go to /admin/config/regional/translate/translate and search (in default language) all strings you have to translate and translate them

This should be enough.

If you are using metatag submodules like Context be aware that translations issues are not still full fixed (see: https://drupal.org/node/1986032)

Hope this help

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.