0

I am working almost 4 hours on the following problem, and can't solve it (Drupal 7).

I tried to build a new simple page in the page manager as I did few times before. I entered a simple path as /xxxx Then, after I saved the page, and tried to load it, I got the following error message:

The requested page "/xxxx" could not be found

Can somebody help me figure out why I can't create new page?

In addition, when I tried to disabled the page on the page manager, I got the following error:

Notice: Undefined offset: 1 in template_preprocess_page_manager_edit_page() (line 42 of D:\MYSITE\sites\all\modules\ctools\page_manager\theme\page_manager.theme.inc

Does someone knows what is the problem, and how can I fix it?

Thanks!

  • Could it be a selection rule or access rule issue in the panel itself? You may also want to ensure the ctools and panels modules are up to date. – David Thomas Oct 1 '13 at 3:07
  • I am sure they are up to date. I double checked it, and ran update.. – EB84 Oct 1 '13 at 7:11
  • Do you have any http response code variants, or any access or selection rules in the page. – David Thomas Oct 1 '13 at 7:14
  • I wish it was that easy.. no http response, no access or selection rules. Thanks anyway! – EB84 Oct 1 '13 at 17:59
1

Are you using the stable version of the ctools and panels module, this error doesn't seems to be in the issue queue of the respective modules.

As @David as mentioned the problem could be of selection rule or the access rule.

Have a look at the use tutorial for creating the page with page manager: http://nodeone.se/en/learn-page-manager-part-1-overview

Also check the documentation of the page manager module: https://drupal.org/node/1862908

| improve this answer | |
  • I used nodeone tutorial two weeks ago - great! I created in past two weeks few pages using page manager, and they are still working correctly. The problem is when creating new page using page manager, I am getting the Errors mention above. p.s. I tried to deactivate and then activate the page manager module. After activated, the link to page manager did not appear on the admin menu- strange. So I decided to restore everything. After restored I could see the link in the admin menu, but still can NOT create new page and still getting the two error mentioned above. Please help figure it out? – EB84 Oct 1 '13 at 7:21
  • @EdenBitton Pleae try this once: After deactivating the module uninstall ("/admin/modules/uninstall") that module also and than clear the cache, and than download the latest stable version of that module and install and than try to work on it. Would be best if you can do the same for both ctools and page manager module – Ankit Agrawal Oct 1 '13 at 7:25
  • One more thing, can you try changing the page path once (whatever path you are using change it to anything else) and check, just to confirm that path doesn't conflicting with any existing pages. – Ankit Agrawal Oct 1 '13 at 7:28
  • @EdenBitton Is your problem resolved or you able to find the issue? – Ankit Agrawal Oct 1 '13 at 9:14
  • Thanks for answering. I develop at home on acuia dev desktop, so I can check only later today, in my home computer. I changed the path few times, and created 4 different pages - did not work (note that pages I created a week ago with page manager are still working properly). If I will uninstall the modules, clear the cache, and install the latest versions - my work will be deleted? Or everything is on the database, and NOTING will be deleted? I do not fully understand the relationship between drupal files to the mysql database.. – EB84 Oct 1 '13 at 9:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.