I recently moved a project from one server to another. the server is running on nginx.

I noticed some issues like that I cant upload any picture to ckeditor using imce module (I can upload images via filefield) then while trying to fix this issue I encountered this problem that I cant enable or disable any module.

It's like when I check/uncheck a module and hit submit on module's list page, it refreshes but nothing change afterwards.

the other thing is Im running another website on this server with the same version of drupal and it just works fine, I wonder what could be wrong? is it a server issue or a drupal problem?

I'd really appreciate any help and tips.

  • Looks that your database became read-only.
    – user11153
    Oct 2 '13 at 9:15
  • is the PHP version on the server more or same as required by different modules.
    – arpitr
    Oct 2 '13 at 9:18
  • if you have drush installed try uninstalling using drush command as drush dis <module_name>
    – arpitr
    Oct 2 '13 at 9:19
  • 1
    thanks for the hints guys, i installed drush, i'll let you know how it works out, about the database read-only issue, how can I check if it is read-only or not? and how to change it? and I'm pretty sure its not HDD because it works just fine with the other site I have on the server
    – Sohail
    Oct 2 '13 at 9:33
  • 2
    how can I check if it is read-only or not? - try creating a node
    – arpitr
    Oct 2 '13 at 9:34

Well I tried alot of approaches, the last thing that I would think of was the solution, it was because clean-url , I just enabled it in server and it start working just fine again.

  • I would love to know how it caused such an interesting effect :D
    – Mołot
    Oct 2 '13 at 9:48
  • 1
    yea the funny thing is I have another website on the server which works just fine without clean-url, but I was so hopeless just fixed the clean-url thing and website is now back to normal working good, I guess it should have to do something with .htaccess files
    – Sohail
    Oct 2 '13 at 10:23

Enabling mod_rewrite solved this problem for me.

Here is a link for how to enable it: https://stackoverflow.com/questions/869092/how-to-enable-mod-rewrite-for-apache-2-2

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.