0

I can't seem to get into the Views administration panel from any place in Commerce Kickstart 7.x-2.9. There is no menu entry even with Administration menu installed. Trying to configure via the link for Views on the modules admin page simply sends the page to the Administration menu with no "Views" option. Likewise directly entering siteurl/admin/views goes to the same place.

I guess the Views access is overridden by the Kickstart configuration.

Does anyone know a way around this?

  • 1
    Is the Views UI module enabled? – Clive Oct 13 '13 at 22:00
  • Yes it is. Clicking on the configure link for it goes to the admin/structure menu with no link for Views. – Clive Woodhouse Oct 13 '13 at 23:04
  • Permissions are also checked for Administer views and Bypass views access control. – Clive Woodhouse Oct 13 '13 at 23:30
  • How about when you visit /admin/structure/views – David Thomas Oct 14 '13 at 1:58
  • @DavidThomas Same result as when I visit admin/structure as above – Clive Woodhouse Oct 14 '13 at 16:21
1

If you have not made any changes and are logged in as admin then the menu link should be under Site Settings -> Visual and Layout -> Views

enter image description here

  • I have the Administration Menu module installed so this does not apply directly. It's not simply a matter of re-activating the Commerce Kickstart menu either - there are problems (see below). – Clive Woodhouse Oct 18 '13 at 18:29
1

I eventually figured this out. With Administration Menu Module installed, views is not available - it seems like the menu links do not get built.

There is a big problem with simply uninstalling the Administration Menu and re-enabling the Commerce Kickstart Menu module. According to https://drupal.org/node/1877594#comment-7500586. "When Commerce Kickstart Menus gets disabled, due to #550254: Menu links are sometimes not properly re-parented Management menu is not being properly rebuilt, hence it will look broken."

In order to get to views I had to uninstall Commerce Kickstart Menu module, apply the patch discussed, then reinstall and re-enable it.

0

The original chosen solution is old and now outdated it seems. All I had to do was go to modules page and disable Commerce Kickstart Menus (if not already disabled) then go to modules uninstall page and uninstall Commerce Kickstart Menus. Now from the /admin/structure/menu/manage/management I can just re-adjust any menus that seem out of place and all control has been relinquished to the UI as would be expected.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.