My request is closest to these two questions:

Filter by multiple taxonomies in URL

Views contextual filters taxonomy name

I have a view which is a page and displays node titles in a table format after the user selects a state, school year, school division, and school using exposed filters. And since each resultset can have dozens of nodes (nodes about that school for that school year) in it, the results are pages of links to 10 nodes at at time. I have exposed filters for state, school year, school division, and school. The view works fine, but the urls for each page of 10 node titles pertaining to an individual school looks like this:


when I would prefer it look like this where instead of term_ids I have terms in the url:


I have created state, school year, school division, and school taxonomies and each node is tagged appropriately with 1 term from each taxonomy.

But when I try to follow the instructions in the above mentioned questions, I get stuck at the part where it says to "specify validation criteria".

I check that box, but I have no options - the options are unavailable.

In the second question referenced above there is a part that says:

"Make sure Specify validation criteria is checked and you should be presented with more options."

[emphasis added]

That is exactly my problem - I should be presented with more options, but I am not.

Can anybody tell me why I am not presented with more options? Am I doing something else wrong?

Thanks in advance.

1 Answer 1


Duh, in case anyone else runs in to this problem:

This really boiled down to after adding a contextual filter, if I clicked any of the checkboxes under the heading "When the filter value IS in the URL or a default is provided":

Override title
Override breadcrumb
Specify validation criteria

I did not see any of the options for any of those checkboxes appear after checking it.

Turns out I didn't have the most up to date version of the chaos tools module.

When I updated to chaos tools 7.x-1.3 (sometimes referred to as ctools) problem fixed.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.