I'm trying to get out some minimally designed pages. The WYSIWYG (CKEditor) has a habit of collapsing the code between saves. WHile this is fine and all, I'm finding myself copying copy and pasting it into sublime text in order to reformat. The copy-pasting -- while not difficult -- is thumbing me up a bit. I've copied/pasted the wrong code and had to redo a lot of my work.

So can I have stop CKEditor from minimizing the HTML code? This is a legacy site in Drupal 6.28.


1 Answer 1


Well I got myself halfway there and without the need to download an additional module, library, or plugin. By checking Apply source formatting and Preformatted, the Disabled Rich Text rendition shows code indented with some of the white spacing preserved.

You can find these settings in D6 via admin/settings/wysiwyg

enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.