0

when I attach an image to my article content type it doesn't show image. I mean when I creat an article content type and I upload an image to its using Image filed of article content type and publishe my article, the image not shown and when I right click to image and clicl "open in new tab" it goes to "Access Denied" page and says you don't have access to this image. this is true for my galley images too. pleas help me :) thanks

1 Answer 1

0

If you have uploaded an image as a private file it is not accessible by other users even if any user has access to the node. Please check "Upload destination" in image field settings.

4
  • no, my Upload destination is set to Public Files. in fact, there is no choice :) and it should be Public Files in addition, I have a gallery that I made it myself. I have this problem there too. but only in gallery page that preview picture as gallery_thumbnail (a cutome view that I created) in fact the original picture shown but the gallery_thumbnail picture not shown :(
    – user21785
    Oct 19, 2013 at 9:38
  • Yes, it should be public to make it accessible to other users, but in fact there are two ways to store images (and other files) - private and public which you can see on the "Image" field setting and on every file itself. Have you checked admin/structure/file-types/manage/image/display and admin/structure/file-types/manage/image/file-display?
    – 0x6d6c
    Oct 19, 2013 at 9:55
  • in admin/structure/types/manage/gallery-image/display when I change the preview to for example thumbnail(100*100) and click Update, it changes but when I refresh the page it is None(original) again. :( I don't know why it never changs?! :(
    – user21785
    Oct 19, 2013 at 17:52
  • please help me :(
    – user21785
    Oct 20, 2013 at 18:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.