3

This error happens just on my local server (I use the last version of Acquia Dev Desktop, kind of XAMP for Drupal), not on our remote servers:

I am suddenly unable to re-order the blocks of our site (Drupal 7.23). The drag-and-drop functionality is not working and entering the weight numbers manually either. I have researched this problem and tried all solutions posted (Aggregate JS, disable LightBox2, change the DB block fields from tiny to INT...).

We have a large number of files in our website, and in some regions they have reached the magic number of 127. Reading a few posts, I see this may be the problem when you have some DB fields defined as tiny, but after changing all the tiny (4) fields of the blocks table to INT(11) I do not see any change.

Any clue?

Thank you very much in advance.

  • 3
    do you have any javascript errors? check console – Victor Oct 22 '13 at 20:08
  • And if not - any 4xx or 5xx HTTP errors? Something in watchdog or server's error.log? – Mołot Oct 22 '13 at 20:38
  • Thanks Victor & Molot. The answer is no to both questions. A new piece of interesting evidence: this error happens just on my local server (I use the last version of Acquia Dev Desktop, kind of XAMP for Drupal), not on our remote servers. – Guan Tanamera Oct 23 '13 at 17:48
  • When you say it is not working - what actually happens? Are you apparently able to save changes? Do you get a message? My guess is you may need to increase the PHP memory limit, by the way. – Alfred Armstrong Oct 24 '13 at 11:08
4

If there's no javascript error in the console, and you have a lot of blocks, and are using the Suhosin extension, you may be hitting a Suhosin limit. If that's the case, you will need to increase the relevant values there. There may be more information in your server error log.

More info: http://www.hardened-php.net/suhosin/configuration.html#suhosin.post.max_vars

| improve this answer | |
  • Thanks David. I have no idea about the Suhosin Extension, but your comment makes sense. This seems a problem associated with the web server, that in this case is Acquia Dev Desktop. This is what the php.ini says: post_max_size = 1000M. Would you recommend to change this value? If yes, what would be your recommended value? – Guan Tanamera Oct 24 '13 at 18:53
2

Check your max_input_vars in php.ini If you have many blocks, this value may be exceeded leading to errors.

Try setting the value to 2000 (I had to use 5000 to cope with a specific site).

| improve this answer | |
1

In my case adding php_value max_input_vars 2000 in .htaccess fixed the problem.

I had to put it between the <IfModule mod_php5.c> tags (which already existed) for it to work, like so:

# PHP 5, Apache 1 and 2.
<IfModule mod_php5.c>
php_value max_input_vars 2000
</IfModule>
| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.