3

I've got a new Red Hat 6.3 server running and Drush installed with a Drupal instance running.

Drush is installed via Pear and here's the output of "drush sitename status" in the Drupal install:

 Drupal version                  :  7.23
 Site URI                        :  http://<hostname>.org                     
 Database driver                 :  mysql                                       
 Database username               :  <mysqluser>                                      
 Database name                   :  <databasename>                             
 Database                        :  Connected                                   
 Drupal bootstrap                :  Successful                                  
 Drupal user                     :  Anonymous                                   
 Default theme                   :  <themename>                                       
 Administration theme            :  seven                                       
 PHP executable                  :  /usr/bin/php                                
 PHP configuration               :  /etc/php.ini                                
 PHP OS                          :  Linux                                       
 Drush version                   :  6.1.0                                       
 Drush configuration             :                                              
 Drush alias files               :/home/<username>/.drush/dev.aliases.drushrc.ph 
                                p                                           
                                /home/<username>/.drush/prod.aliases.drushrc.p 
                                hp                                          
 Drupal root                     :  /var/www/<sitename>                   
 Site path                       :  sites/default                               
 File directory path             :  sites/default/files                         
 Private file directory path     :  sites/default/files/private                 
 Temporary file directory path   :  /tmp 

I have a drushrc.php files in sites/all/drush and but it's not registering, hence the blank entry in "Drush configuration" above. Whenever I run any drush commands on these sites, it just outputs the contents of the drushrc.php file.

I have the exact same codebase running on my local server (Kubuntu 13.04 with the same version of Drush) and it is recognizing the drushrc.php file so I'm assuming that it's not the file itself.

Drush, including all aliases, is working exactly as expected except for the screen output of the drushrc.php file mentioned above.

Here's the output of "drush -d status" running outside the Drupal install:

    Bootstrap to phase 0. [0.01 sec, 3.78 MB]                            [bootstrap]
    Drush bootstrap phase : _drush_bootstrap_drush() [0.01 sec, 3.98 MB] [bootstrap]
    Cache HIT cid: 6.1.0-commandfiles-0-068c4f324233e194887820ad3c8ded3a      [debug]
    [0.02 sec, 3.99 MB]
    Bootstrap to phase 0. [0.09 sec, 9.16 MB]                             [bootstrap]
    Found command: core-status (commandfile=core) [0.13 sec, 9.16 MB]     [bootstrap]
    Loading outputformat engine. [0.21 sec, 9.2 MB]                          [notice]
    Calling hook drush_core_status [0.21 sec, 9.25 MB]                        [debug]
    Returned from hook drush_core_status [0.21 sec, 9.25 MB]                  [debug]
    PHP executable        :  /usr/bin/php                                  
    PHP configuration     :  /etc/php.ini                                  
    PHP OS                :  Linux                                         
    Drush version         :  6.1.0                                         
    Drush configuration   :                                                
    Drush alias files     :  /home/<username>/.drush/dev.aliases.drushrc.php  
                              /home/<username>/.drush/prod.aliases.drushrc.php 
    Command dispatch complete [0.21 sec, 9.29 MB]                            [notice]
    Peak memory usage was 11.19 MB [0.22 sec, 9.29 MB]                       [memory]

Any advice welcome.

6

Whenever I run any drush commands on these sites, it just outputs the contents of the drushrc.php file.

Make sure your sites/all/drush/drushrc.php has an opening <?php tag at the head of the file.

Also, you'll need to clear drush's cache when you add new site aliases.

drush cc drush
  • 1
    Ouch ... thanks. The file was open with '<?' instead of '<?php' but it was working fine on my Ubuntu systems ... RHEL was not as forgiving. – user23136 Oct 24 '13 at 21:05
  • The dreaded short tags! Glad you got it sorted. – jonpeck Oct 24 '13 at 21:11
1

If you installed drush via composer:

$ cp ~/.composer/vendor/drush/drush/examples/example.drushrc.php ~/.drush/drushrc.php $ drush cc drush $ drush status

You should notice:

Drush configuration : /home/<username>/.drush/drushrc.php

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.