1

I have a view which displays a content type in a grid and is working fine.

The content type has a taxonomy field - so when a node is created the user selects a taxonomy term from a list (Hierarchy) - it is then displayed on the node once posted.

In my view I have added 'Content: Has taxonomy term' under 'Filter criteria' but i'm not sure how to get it to work. On the block the user sees I would like them to be able to type a term into an auto complete field which will then change the content which is displayed in the view. I have chosen 'Auto Complete' as the selection type in my filter criteria section and I have ticked the box which says 'Expose this filter to visitors'. The view is working and is displaying content but there is no option presented to the user to change the filter term.

How can I do this please?

Thanks

0

You've done everything right. However, there's a kind of a usability problem with Views, Blocks and Exposed Filters. You can include the exposed filters within the views block by editing the View, then changing "Use AJAX" to yes. Specifically:

Advanced > Other > Use AJAX: Yes

  • Hi, Thanks for the help. This is kind of giving me a result but with 1 problem, I cant see anything in my block after setting AJAX to Yes however I can see the filter is now displayed in the views preview. Do you know what the reason for this would be? Thanks for your time. – aaron Oct 26 '13 at 23:01
0

Never mind, I found it, I had the 'Required' field checked, I un-ticked it and now all content shows by default and works how I want it :)

Thanks for the help

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.