-1

This question already has an answer here:

I am using Drupal 7 and have installed a translation module and enabled node and content translation, but I have a problem: In page /admin/content or node/add the content name is not translated. I translate the content name string in the translation interface but they are not translated in related pages such add or manage content.

Please tell me how can I translate content type names.

marked as duplicate by Patrick Kenny, Free Radical, Mołot, monymirza, Chaulky Oct 28 '13 at 22:02

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • If string was found in translation interface, then you did everything all right and it's probably a cache problem. Can you tell us exactly what you did, step by step? Maybe you translated string that is just similar?.. – Mołot Oct 27 '13 at 8:28
3

Provided you're site is using a single (non-English) language, and you've installed the content type modules before you enabled the translation module, you have this problem because the strings with the content names are already imported into Drupal and any translation done after that point in the translation interface will not have any effect (unless you uninstall the content type, and then reinstall it again).

Instead of toggling installation (which may wipe out any content associated with the content type), navigate to Administration » Structure » Content types and click Edit for the content type you want to translate.

There you will see the human-readable name of the content type in a text field. Edit this field to the translated string you want, and click Save content type.

(The same goes for the other fields that appear in the content type UI, such as "Description" and field names.)

However, if your site is multi-language, I really think this is a bug in the Internationalization module, and as such is off-topic here. See Translate interface for nodes, fields, etc. show wrong language in the column for the issue.

However, I was able to get the node types translated at my site by doing the following:

First, I made sure that I installed the Internationalization module before I added any languages. I also made sure that I used English as the default language all the way during the translation process.

So you do the following with English as the only language enabled (if you've got additional languages enabled, uninstall them, you will also need to disable and uninstall the Internationalization module and all its helper modules to get a clean start):

  1. Download and install the [Internationalization] project.
  2. Enable the Multilingual content module.

Then add any additional languages you want, but do not enable them. This is supposed to add translations for the Node types, but this may not happen (due to the bug I mentioned initially).

You can confirm this by looking under the "Overview" tab of the translation interface:

Overview 1

If the percentage in the "Node types" for your second language is ("Norwegian Bokmål" in the image above) is 0%, the translated strings for the Node types has not been imported into the translation interface, and after you enable that language, the English strings will appear since there are no translated strings yet.

However, it should now be possible to add these translation by hand. Navigate to the translate tab of the translation interface, and limit search to Node types.

Translate

The strikethrough over the string with the two letters in the Languages column means that the translation is missing. Click "edit" to add the missing translation.

This exact procedure fixed it for me as can be seen from the "Overview" tab below. The percentage for "Node types" for "Norwegian Bokmål" in now 100%.

Overwiew 2

After doing all the above, it is OK to set a non-English language as default.

  • I have 2 language and my site is multi language, sorry content type module is installed by default in drupal !!! after it I install translation modules, the description of content type translated correctly and work fine but the content type name not translating effected :( – Yusef Oct 27 '13 at 12:50
  • It looks link only answer, please add the essential part. – Bala Oct 27 '13 at 13:33
  • ya its a duplicate, for that you have to flag it as duplicate. no way this to be accept as answer, even it don't have any information for the question, just only the link to that post, otherwise it will be a low quality post. :) – Bala Oct 27 '13 at 13:43

Not the answer you're looking for? Browse other questions tagged or ask your own question.