1

I have a view that displays content in a table form so admins can quickly look through the content. There are two displays (pages).

Page1: Lists all content and exposes the filters for type and published to the user so they can narrow down there view. But initially all content should be displayed.

Page2: Has criteria set to show only type=photo and published=no.(not exposed)

Everything else is the same between the two.

The filters on page2 are affecting page1. When you first land on page1, the filter controls say -any- and -any- but the view is filtered to type=photo and published=no (page2 filters). If you hit apply the filters are removed, but you can see how this could be confusing to users.

How can I prevent the filters on page2 of the view from affecting page1.

2

Whenever you apply any filter criteria / sort criteria / contextual filters / relationships; you have to make sure you apply settings to current display (page/block) only. In this way the current setting doesn't interfere with other displays.

snapshot

  • I did that. In the views configuration page the it does not show up that page1 should be filtered. – Dan Oct 29 '13 at 15:03
  • @dan08 It should be good. could you provide export of your view? That way could be easy to debug. – AjitS Oct 29 '13 at 15:08
  • My bad. published=no was the default for the exposed filter even though it was displaying -any-. And the only unpublished content are photos. It works after changing that. – Dan Oct 29 '13 at 19:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.