0

I'm using Drupal 6.28 and there's something i don't understand.

i have a page that contains an image tag pointing to an absolute path. e.g.

<img alt="google logo" src="http://www.google.com.sg/images/srpr/logo11w.png" style="height:190px; width:538px" />

when the content is saved, drupal returns a "Page Not Found" error.

i found out that if i remove the "http:" at the start of the src attribute, there wouldn't be any problem. everything would be ok. i.e.

<img alt="google logo" src="//www.google.com.sg/images/srpr/logo11w.png" style="height:190px; width:538px" />

is there some setting that i may have messed up that causes this?

Thanks

7
  • 1
    Strangeness with saving aside, you really shouldn't be hotlinking images like that.
    – jonpeck
    Oct 31, 2013 at 4:14
  • Just check if there is any text filtering happening. You should find it in text formatting settigns. Oct 31, 2013 at 4:16
  • thanks for the replies. i tried turning off the text filters, but this didn't help.
    – G Stamp
    Oct 31, 2013 at 7:11
  • What modules do you have installed on your site?
    – hargobind
    Oct 31, 2013 at 7:30
  • hi, @hargobind i have the following modules installed and enabled: CiviCRM, Core - Color, Database Logging, Help, Menu, Path, Taxonomy, Update Status, Elysia Cron, Login Security, CKEditor, Webform One additional information that i missed to point out is that drupal is installed on a subdomain. e.g. sub1.mydomain.com not sure if this matters. Thanks.
    – G Stamp
    Nov 7, 2013 at 0:47

1 Answer 1

1

the issue i reported was caused by a mod_security setting. my host fixed it after i spoke to them.

2
  • Good to know. Could you make them to tell you what they changed? And then share this with us?
    – Mołot
    Nov 19, 2013 at 9:33
  • 1
    hi guys, it turns out that it was caused by some mod_security setting by my host. when i asked them what they changed to fix it, all they said was that they white listed something.
    – G Stamp
    Jan 16, 2014 at 7:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.