0

I'm using the GeoField module to geocode fields for mapping on my site. There is an issue with the current stable release of this module.

If Widget Type is "Geocode from another field" this field must be marked REQUIRED or GeoField will create this error:

Notice: Undefined index: default_value in geofield_field_presave()

Is there a way in Drupal 7 that based on the widget type you can FORCE the required option for a field? This would be a solution to this problem. Thanks!

  • Just to clarify, are you trying to force the "Required" checkbox to be checked (and perhaps disabled) when creating/editing the settings for a field which uses a certain widget type? If so, that bit would be pretty easy. The harder bit would be automatically managing/updating the "required" state on the field any time the widget is changed – Clive Nov 1 '13 at 14:52
  • Correct..forcing the "Required" checkbox per widget is what I'm after. – Ken J Nov 1 '13 at 14:59
  • 1
    All is I see is "Force Field", which I honestly thought was beyond Drupals capabilities. Awesome. – Letharion Nov 5 '13 at 14:02
0

you can group them together with field group, and then mark that group as required.

but the manual work in the Field UI is neede here ..

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.