1

I want to do the same as what is shown in the video about the Views Isotope module, but within Commerce Kickstart (CK).

Gareth Hall, shows us how to drupal 7. I've done the same for CK, but I can not get that purpose, that is, not filtered. I click on the tags and does not give any effect or filter.

I thought it might not be compatible with CK or perhaps is making a conflict with some jQuery or something out there.

Please any suggestions?

Update:

  • I installed the module View Isotope
  • I activated "Isotope Example" and "Views Isotope" modules
  • I created two views (and filter for content) as explained in the video.
  • I have also used the version "Isotope Example", for that I have added content in "tags" and "articles".

And still the same. does not filter anything.

Now, also I have since only a new version of Drupal 7 (without CK). For this I needed to install/activate other modules, such as: Features (enabled), Image (enabled), File (enabled), Field (enabled), Field SQL storage (enabled), Taxonomy (enabled), Options (enabled), Views (enabled ), Chaos tools (enabled), Views Isotope (enabled), jQuery Update (enabled), Libraries (on)

And still the drawback.

I am convinced that something is missing but I do not know why.

Any help?

  • Could you write down the exact steps you followed and at which point you noticed that the tags don't work? – Patrick Kenny Nov 8 '13 at 6:10
2

Views Isotope works fine with Drupal commerce. (I'm using it now =-)

Make sure you have the isotope .js file in the correct location within libraries: sites/all/libraries/jquery.isotope/jquery.isotope.min.js

also when creating the View make sure (as the above video briefly covers) that the 'Taxonomy Term: Name' in the Views Isotope filter block has the 'link this field to its taxonomy page' option turned off (5:25 time in the YouTube tutorial you posted). If it is on the links wont work.

And of course as video stresses in the main Isotope View, make sure the last field in the list is the taxonomy field that is linked to the header block. IF you need to display that taxonomy also create two fields in the view and make sure one of them is last with the correct CSS overwrite styling as the video tutorial states.

Oh and lastly, make sure your Views' Ajax option in the advanced tab is turned off. It conflicts with Isotope and wont work.

0

Try to solve some :) Adding to "sites / all / libraries", A Script. Isotope js (I found out there ...) and leave it like this: "besiege / all / libraries / jquery.isotope / jquery.isotope.min.js" This is perfect just for drupal 7 version. (the one I installed)

But I still have problems with Kickstart commerce for more than try, That not filter me anything ... I now search for, how to install new libraries for CK?. But I do not find something positive.

I will continue investigating.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.