1

I use:

  • Drupal 7.23
  • i18n-7x-1.10
  • Language icons 7.x-1.0
  • APC 7.x-1.0-beta4

I have activated the Menu Translations sub module for translate the items of main menu. My language negotion is by URL.

When I enter to my site with: http://domain.com, the menu translate works fine. It only shows the items for the active language.

But when I enter to my url with: http://www.domain.com, not work the translate. All main menu items appear (in all languages). No respect the Negotiation for URL.

Then, to inspect my settings on the main menu I have the following:

  • MULTILINGUAL OPTIONS
  • Translation mode --- Translate and Localize. Menu items with language will allow translations. Menu items without language will be localized.

But, when I set this configuration (in mode admin) with the URL: www.domain.com and then click on save button, appear the error:

PHP Fatal error: Call to undefined method i18n_object_wrapper::strings_update() in /sites/all/modules/contrib/i18n/i18n_string/i18n_string.module on line 851

But, no appear when I save this configuration with the URL: http://domain.com

Moreover, with "www" option disappears the option for translate menu items. So, all items that were translated earlier are considered as a normal item menu and shows all. This does not happen when only income, "http://"

Example

(http://domain.com/en - version english) Item1-en Item2-en Item3-en

(http://domain.com/es - version spanish) Item1-es Item2-es Item3-es

(http://www.domain.com - version spanish or english) Item1-en Item2-en Item3-en Item1-es Item2-es Item3-es

Screenshot1

Screenshot2

Screenshot3

Screenshot4

  • Did you set the default methods to set the language? I think the problem is not with www but with the language settings. Visit admin/config/regional/language/configure to see your language detection. – Gladiator Nov 8 '13 at 5:55
  • @Gladiator I set in my configuration Method Detection by URL. I think that is a problem with i18n module. With http works fine. But, with http://www. No – Dvex Nov 8 '13 at 14:40
  • @Gladiator I update the description of my question. – Dvex Nov 8 '13 at 15:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.