2

I need infinite scrolling for a View. I installed Views Infinite Scroll, and it will work if I set jQuery Update to version 1.8, but when it loads the next page, it leaves the pager in plain site. I don't want the pager to display, and I can't figure out how to disable it. Also, when it's loading the next page of content, it displays that ugly progress GIF. Is there a way to hide that as well, and just get a nice scroll functionality, like on Twitter?

I don't know if this is causing an issue, but my View results are nodes, using Display Suite view mode. In these nodes, I have another View that displays product pricing and other fields, using Commerce Add To Cart Extras. Would this other View (in each node) conflict with the Views Infinite Scroll module for my main View?

If I have to do this through code, what is the best route? Should I use the Views Ajax API somehow, or is there another JS or jQuery library that I can integrate with Views?

I tried to use the Views Load More with Wayports, but I couldn't get that to work either. The best I got was the View to just display the "Load More" link, which I don't want.

  • If it loads the next page and leaves the pager displayed, it means that probably the CSS is being overridden - inspect element and see if theme's styles are forcing the pager to be visible. If not, check the console log for any JavaScript errors. – Aram Boyajyan Nov 11 '13 at 7:56
  • I disabled my theme's CSS for pagers (I'm using Omega 3) and that doesn't help, and there are no JavaScript errors in devtools. Another anomaly is when I get to the end of the scroll, it doubles up again, except without the images. – vintorg Nov 11 '13 at 20:07
  • and since it only works with jQuery 1.8, my Views UI behaves oddly. – vintorg Nov 11 '13 at 20:13
  • Did you try switching the theme to Bartik? If everything works when you switch it, it's probably something in your theme causing the issue. – Aram Boyajyan Nov 11 '13 at 20:59
  • I haven't. It's a live site, so I need to figure out how to try that. – vintorg Nov 11 '13 at 23:05
0

To hide the pager, I just set the display: none in the CSS.

  • it works, but surely that is a bug? – coderama Nov 20 '14 at 11:23
0

Here's an issue regarding this in Drupal.org.

https://www.drupal.org/node/1234704

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.