2

I am developping a filter to render equations in nodes as images from LaTeX code using mathtex library ( http://www.forkosh.com/mathtex.html ).

The filter works quite well, my filter is active, the content is filtered, the node is cached using Boost and the HTML file is containing teh filtered HTML code.

BUT : after several minutes (arround 45 minutes) my filter is disabled (not visible in the input format adminpage, see below) despite that the module is still activated in the module page and the content is not filtered anymore. BUT : when I desactivate/reactivate the modules, OR when I delete all caches, the filter is reactivated, the content is filtered again. And approximatively 45 minutes after it's not filtered anymore.

I try to do the same filter but using the Custom Filters module and I had the same behavior.

I supposed that the cron job had an influence, but content become not filtered BEFORE cron is executed (every hours).

Someone has an idea from where does the problem can come from ?

I'm running : Drupal 7.23 using lots of modules : http://sites.uclouvain.be/selt/files/selt-modules.txt

Some captures to illustrate :

Content not filtered, as after approximately 45 minutes : Content NOT filtered

Content filtered, as after cache flushing or de/reactivation of module : Content filtered

Administrative page for format "Full HTML" showing activated mathtex filter : Mathtex filter is activated after flush of caches

Administrative page for format "Full HTML" not showing filter : Mathtex filter is NOT activated before flush of caches

  • Please do not add solutions to a question. Solution should be posted as an answer. Also, don't add [solved] to title. Mark one of the answers as accepted to show this question was answered to your satisfaction. – Mołot Jan 31 '14 at 8:51
1

After several tests and investigations, the culprit was the distant MySQL server which had a too short wait_timout. During cache refreshing operations the server used to go away before filters beeing applyed, leading to caching unfiltered pages. Using a MySQL server with no wait_timeout has solved this problem, without changing any setting elsewhere.

0

Suggestions to debug:

  1. Simplify the setup -- limit your installation to a simple, fresh drupal with only your filter module. No unknown influences, to pinpoint the flaw.
  2. If you suspect cron -- turn it off and wait 60 minutes.

But this is individual support. No other user might ever benefit from your very individual problem. It is not a good fit for a public question on stackexchange.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.